İndis ve Kaçıncı Formülleri


İndis ve Kaçıncı formülleri, tablonuzda birden çok ölçüte dayalı verileri bulmanızı sağlar.

İngilizce terimleri INDEX ve MATCH olarak kullanılan bu fonksiyonlar, bazen hayati derecede zaman kazandırıyor. Tabi kullandığınız tablolar binlerce satırlık veriyi içeriyorsa bunu öğrendikten sonra ne demek istediğimi anlayacaksınız. Benzeri olan daha önceki anlatmış olduğum konulardan Düşeyara fonksiyonu kullanımı ile yakın görevlerde olduğunu düşünebiliriz. İNDİS ise bu sistemin biraz daha gelişmiş versiyonu diyebilirim. Sorularınızı istediğiniz gibi değiştirebilir ve İNDİS sayesinde sonuçları getirebilirsiniz.

Basit bir örnek ile anlattıklarımızı canlandıralım, ilk olarak aşağıdaki il, ilçe tablomuzdan İNDİS formülü ile aranan sonucu bulalım.

İl İlçe Nüfus
Adana Ceyhan 10000
Bursa Osmangazi 25000
Antalya Alanya 20000

=İNDİS(A1:B3;2;2) A1:B3 aralığındaki 2. satır 2.sütunun kesişiminde bulunan değeri getirir. Osmangazi
=İNDİS(A1:B3;3;1) A1:B3 aralığındaki 3. satır 1.sütunun kesişiminde bulunan değeri getirir. Antalya
                 ? A1:A3 aralığında en yüksek nüfusa ait Şehri getirir. Bursa

Şimdi işi biraz daha ilerletelim ve formül içerisinde Kaçıncı ve Maksimum fonksiyonlarını ekleyerek, aradığımız değeri bulalım.

Yukarıdaki örnek şehir tablosundan en yüksek nüfusa ait şehri bulabilmek için şu formülü uygulayabilirsiniz.

=İNDİS(A1:A3;KAÇINCI(MAK(C1:C3);C1:C3;0)) – Burada anlatılmak istenen, A1:A3 aralığındaki dizinde, C1:C3 aralığındaki Maksimum değeri C1:C3 aralığında aratıp bul ve A1:A3 aralığındaki değerle eşleştirip getir.

————————————————————————————————————————————————–

Bu örnekleri bir de aşağıdaki veri tablomuzda uygulayalım. Bu sefer sorularımızı biraz daha zor olacak.

indis tablo1

Tablomuzda satış personellerinin haftalık satış miktarları ve tutarları mevcuttur. Sorularımız sırasıyla şu şekilde;

  • Listemizde hangi personel 1799TL satış yapmıştır ?
  • En az müşteri ile ilgilenen personel kimdir ?
  • Listede en çok satış yapan personel kimdir ?

Hemen ilk soruyla yanıtlamaya başlayalım;

 

  • Listemizde hangi personel 1799TL satış yapmıştır ?

=İNDİS($B$4:$B$16;KAÇINCI(1799;$D$4:$D$16;0)) – Kırmızı renk ile belirttiğim alana soruyu yazıyoruz. Burada 1799 yerine başka bir değer yazarsanız size o sonucu getirecek.

 

  • En az müşteri ile ilgilenen personel kimdir ?

=İNDİS($B$4:$B$16;KAÇINCI(MİN($C$4:$C$16);$C$4:$C$16;0)) – Min – miminum anlamına gelir, bunun yerine maksimum değeri için Mak yazıp sonuç alabilirsiniz.

 

  • Listede en çok satış yapan personel kimdir ? – Bu soruyu da sizlere bırakıyorum. Yukarıda benzer bir işlevi uygulamalı olarak anlamıştım. Örnek dosyamıza ulaşarak bu soruyu çözebilirsiniz.

Örnek Çalışma Dosyası İndis Formülü Kaçıncı Mak-Min – İndir


İndis ve Kaçıncı Formülleri” için bir yorum

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir