Excel Eğersay, Veri Doğrulama, Etopla İşlevleri


Eğersay, Veri Doğrulama, Etopla

Excel’de seçilen bir satır veya sütunda, belirlediğiniz kurala uygun olan değerlerden kaç tane olduğunu bulabilmek için EĞERSAY formülü kullanılır. Örnekle başlayalım;

Aşağıdaki listede ülkelere verilen malzemelerin fiyat tutar listesi mevcuttur. Örnek Excel dosyamızda bu liste 100 satıra kadar gitmektedir.

Liste

Şimdi bize bu listeden EĞERSAY işlevi ile, Fransa’nın listede kaç defa adının geçtiğini saydıralım.

Eğersay Ülke

Uyguladığımız EĞERSAY işlevine ek olarak, daha önce sizlere anlatmış olduğum ETOPLA, ÇOKETOPLA konusunda bulunan formülleri de kullanabilirsiniz, böylece Fransa’ya yapılan sevkiyatın toplam tutarını ETOPLA formülü ile sonuç getirebilirsiniz. (bkz. Yukarıdaki Resim)

Bu çalışma dosyanıza bir güzellik daha katmak isterseniz, resimdeki gibi Bir Ülke Seç opsiyonunu da ekleyebilir, bunun sayesinde bir Ülke listesi oluşturup, formüllerin otomatik çalışmasını sağlayabilirsiniz. Yani siz hücreden Ülkeyi seçin ve karşılığında formüllerinizi çalışsın. Uygulama için herhangi bir hücreye (Biz örnek dosyamızda E8 hücresine uygulamak istiyoruz)  tıklayıp,

Veri > Veri Doğrulama sekmesini açtıktan sonra, (bkz. Resim)

İzin Verilen Liste > Kaynak > =$A$2:$A$19    yazmanız yeterli olacaktır.  (bkz.Aşağıdaki Resim)

Veri doğrulama

Bu adımları uyguladıktan sonra E8 hücresinde açılıp kapanabilen bir ülke listesi oluşacak. Böylece istediğiniz ülkeyi seçip Eğersay ve Etopla formüllerinin otomatik sonuçlar getirmesini sağlayabilirsiniz.

Konunun en başında bulunan hareketli gif resimde görüleceği üzere, oluşturduğumuz veri listesinden Ülkeyi seçerek işlem yapabilirsiniz.

 

Bir alternatif daha deneyelim, bu sefer Demir Platin Bronz satışlarını çıkartalım, bunun için E1 hücresine Demir, E2 hücresine şu formülü yazın.

=EĞERSAY($B:$B;E1)   –   Bunun anlamı, B:B sütunundaki Malzeme listesinden E1 sütunundaki Demir olanları say ve sonucu getir.

Screenshot_1

Yukarıdaki gibi, Platin ve Bronz isimlerini aratarak sonuç getirebilirsiniz.

 

Bu konumuzda neler öğrendik kısaca özetleyelim;

  • Eğersay formülü ile bir aralıktaki değerleri saydırmak,
  • Veri doğrulama ile bir hücrede açılıp kapanabilen Ülke listesi oluşturmak,
  • Etopla formülü ile ülkelerin toplam satış tutarlarını öğrenmek,

Umarım faydalı olmuştur. Örnek dosya için aşağıdaki linkten dosyamızı indirebilir ve çalışabilirsiniz.

Sağlıcakla kalın, başarılar…

Eğersay işlevi Örnek Dosyamızı İndirebilirsiniz… >

 

 


Excel Eğersay, Veri Doğrulama, Etopla İşlevleri” için bir yorum

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir